Group phone numbers 0880026500 and 0880026599 not available
Incident Report for Invantive
Resolved
The Call Queues on +31880026500 and +31880026599 are available again.
Posted Nov 24, 2021 - 09:20 CET
Update
The call queues 500 and 599 are still not available. Also outbound the Teams PBX does not function well. Please use direct number +31880026501 or +31880026518 for agent.
Posted Nov 22, 2021 - 16:02 CET
Identified
Invantive is currently not available by phone through +31880026500 and +31880026599. Please use +31880026501; you will be forwarded to your party from there.
Posted Nov 16, 2021 - 15:23 CET
This incident affected: Invantive Corporate (PBX).