Exact Online APIs very slow, leading to timeouts
Incident Report for Invantive
Resolved
Exact Online API performance is again regular.
Posted Dec 03, 2022 - 10:46 CET
Update
#ExactOnline API performance remains very slow. The 95-percentile for API response times is approximately 10 to 20 times higher than last week. For details see picture below or search on https://status.invantive.com for "Exact Online REST API 95p".
Posted Dec 02, 2022 - 13:44 CET
Update
Slow to very slow performance of the ExactOnline APIs is "normal" at typically days 1 to 8 of the calendar month due to accounting departments prepare VAT and other financial statements, and updating internal and external reports. Typically the performance problem disappear when the accounting departments have finished their monthly chores.
Posted Dec 02, 2022 - 11:47 CET
Update
Various #ExactOnline APIs currently display a bad performance which is between 4 and 10 times slower than normal. A limited number of calls exceed the time out of over 20 seconds for an API request (normally between 0.2 and 2 seconds). Your real-time reports and analyses may run up to 10 times slower than normal.
Posted Dec 02, 2022 - 11:45 CET
Investigating
We are experiencing a lot of timeouts due to the Exact Online APIs being very slow. These seems to be the case on all endpoints and across multiple countries. There is nothing we can do at this time to minimize the impact. You can recognize these timeouts by checking your logging for message code itgenoda324.
Posted Dec 02, 2022 - 10:36 CET
This incident affected: Platforms (Exact Online).