Bad request errors on Visma.net APIs
Incident Report for Invantive
Resolved
The problems on Visma.net APIs have been resolved by reverting to a pre-9.33 release version of the metadata. The new metadata seems already to include changes for the future upgrade from VNI authentication to Visma Connect Authentication.
Posted Feb 15, 2023 - 16:54 CET
Update
There seem to be large and breaking changes on the Visma.net APIs using Swagger for which we are currently trying to receive documentation and/or confirmation on.
Posted Feb 09, 2023 - 15:08 CET
Update
The frequency of HTTP 400 Bad Request error has decreased by a factor of 10, but is still occurring. Outage level for Visma.net API from Major to Partial.
Posted Feb 06, 2023 - 18:31 CET
Update
The error occurs among others on SupplierInvoices, Branches, CurrencyRate, SupplierInvoiceLines and Accounts.
Posted Feb 03, 2023 - 23:01 CET
Investigating
Since February 2 and especially on February 3, intermittent HTTP 400 Bad Request errors occur across many Visma.net Financials APIs. The error code is itgenclr083. In a next release, a separate error code will be introduced.

It is currently unclear what the cause of the #Vismanet API errors is.
Posted Feb 03, 2023 - 22:54 CET
This incident affected: Platforms (Visma.net).