400 Bad Request errors on Exact Online app authentication across all apps, including external
Incident Report for Invantive
Resolved
#ExactOnline seems to have replaced the log on form for use by apps consistently with their new version. The new version can be recognized by the Next button having the same width as the user name field. The new version resolves the initial 400 Bad Request message when logging on to an app.
Posted Nov 18, 2022 - 08:28 CET
Update
Een nieuwe Exact Online-release lijkt het gedrag te veranderen. Als het eerste aanmeldscherm een "kleine" Next-knop bevat, dan wordt in het volgende scherm niet meer om het wachtwoord gevraagd, maar het #ExactOnline aanmeldscherm getoond met de grote "Next"-knop. Aanmelden geeft dan - benevens enige verwarring - dan geen 400 Bad Request meer.
Posted Nov 14, 2022 - 13:43 CET
Update
Log on errors to #ExactOnline apps seem to be uniquely related to the type of log on form. A log on form with SQUARE corners on buttons and text entry field will result in a "HTTP 400 Bad Request". A log on form with rounded corners on buttons will allow connection to be established. For more information, please follow https://forums.invantive.com/t/400-bad-request-when-logging-in-to-exact-online-on-get-my-report-valuta-tools-exact-support-invantive-cloud/2854
Posted Oct 22, 2022 - 11:59 CEST
Identified
Across all #ExactOnline apps, from Invantive but also at least one from Exact itself, a 400 Bad Request occurs when acquiring access. For the so-called "Code Grant Flow" with a long-term memorized refresh token the workaround is to retry the operation, such as on Invantive Cloud. For the so-called "Implicit Grant Flow" and non-memorized refresh token as on for instance Invantive Get My Report and Invantive Control for Excel the authentication has to be retried on every use. The cause and resolution of the error is unknown, but out of our control. The incident ONLY affects Exact Online. For more information, please follow https://forums.invantive.com/t/400-bad-request-when-logging-in-to-exact-online-on-get-my-report-valuta-tools-exact-support-invantive-cloud/2854
Posted Oct 21, 2022 - 09:46 CEST
This incident affected: Platforms (Exact Online).